상단메뉴 바로가기 본문 바로가기 본문 하위메뉴 바로가기 하단 바로가기

KISA 보안공지

Apache Log4j 보안 업데이트 권고(CVE-2021-45105, 44832, CVE-2022-23302, 23305, 23307) (Update. 22-1-21 17:00)2021.12.18

2021-12-18 : CVE-2021-45105 취약점 보안 업데이트
2021-12-20 : 조치방안 내 오타 수정
2021-12-22 : 대응방안 업데이트(Java 6, 7 대상)​
2021-12-29 : CVE-2021-44832 취약점 보안 업데이트
2021-12-30 : Log4j 2.12.4, 2.3.2 다운로드 추가
2021-12-31 : 영향을 받는 부분 수정
2022-1-3 : 영향받는 버전 수정
2022-1-21 : CVE-2022-23302, 23305, 23307 취약점 관련 내용 추가

□ 개요
 o Apache 소프트웨어 재단은 자사의 Log4j에서 발생하는 취약점을 해결한 보안 업데이트 권고[1]
 o 공격자는 해당 취약점을 이용하여 정상 서비스 중지 등의 피해를 발생시킬수 있으므로, 최신 버전으로 업데이트 권고
    ※ Log4j 취약점을 이용한 침해사고 발생시 한국인터넷진흥원에 신고해 주시기 바랍니다.

□ 주요 내용
 o Apache Log4j 2에서 발생하는 서비스 거부 취약점(CVE-2021-45105)[2]
 o Apache Log4j 2에서 발생하는 원격코드 실행 취약점(CVE-2021-44832)[4]
 ​o Apache Log4j 1에서 발생하는 원격 코드 실행 취약점(CVE-2022-23302)[6]
 o Apache Log4j 1에서 발생하는 SQL Injection 취약점(CVE-2022-23305)[6]
 o Apache Log4j 1에서 발생하는 원격 코드 실행 취약점(CVE-2022-23307)[6]

    ※ Log4j : 프로그램 작성 중 로그를 남기기 위해 사용되는 자바 기반의 오픈소스 유틸리티

□ 영향을 받는 버전
 o CVE-2021-45105
   - 2.0-alpha1 ~ 2.16.0 버전 
      ※ 취약점이 해결된 버전 제외(Log4j 2.3.1, 2.12.3 및 이후 업데이트 버전 제외)
 o CVE-2021-44832
   - 2.0-beta7 ~ 2.17.0 버전
      ※ 취약점이 해결된 버전 제외(Log4j 2.3.2, 2.12.4 및 이후 업데이트 버전 제외)
 o CVE-2022-23302
   - 1.x 버전
      ※ JMSSink를 사용하지 않는 경우 취약점 영향 없음
 o CVE-2022-23305
   - 1.x 버전
      ※ JDBCAppender를 사용하지 않는 경우 취약점 영향 없음
 o CVE-2022-23307
   - 1.x 버전
      ※ Chainsaw를 사용하지 않는 경우 취약점 영향 없음


□ 대응방안
 o 제조사 홈페이지를 통해 최신버전으로 업데이트 적용[3]
   ※ 제조사 홈페이지에 신규버전이 계속 업데이트되고 있어 확인 후 업데이트 적용 필요
  - Java 8 이상 : Log4j 2.17.1 이상 버전으로 업데이트
  - Java 7 : Log4j 2.12.4 이상 버전으로 업데이트[5]
  - Java 6 : Log4j 2.3.2 이상 버전으로 업데이트[5]
     ※ log4j-core-*.jar 파일 없이 log4j-api-*.jar 파일만 사용하는 경우 위 취약점의 영향을 받지 않음
     ※ Apache Log4j 1.x 버전은 2015년 수명이 종료되어 ,1.x 버전 사용자는 Log4j 2로 업그레이드 필요

 o 신규 업데이트가 불가능할 경우 아래의 조치방안으로 조치 적용
  - CVE-2021-45105
     · PatternLayout에서 ${ctx:loginId} 또는 $${ctx:loginId}를 (%X, %mdc, or %MDC)로 변경
     · ${ctx:loginId} 또는 $${ctx:loginId}를 제거
   - CVE-2022-23302
      · JMSSink 클래스 파일 삭제
zip -q -d log4j-*.jar org/apache/log4j/net/JMSSink.class
  - CVE-2022-23305
      · Log4j 설정 파일에서 JDBCAppender 삭제
      · JDBCAppender 클래스 파일 삭제
zip -q -d log4j-*.jar org/apache/log4j/jdbc/JDBCAppender.class
  - CVE-2022-23307
      · Chiansaw를 통해 직렬화 된 로그를 읽지 않도록 설정 (※ XMLSocketReceiver로 대체 가능)
      · Chainsaw 관련 클래스 삭제
zip -q -d log4j-*.jar org/apache/log4j/chainsaw/*


□ 침해사고 신고
 o 한국인터넷진흥원 인터넷침해대응센터 종합상황실(02-405-4911~5, certgen@krcert.or.kr)
 o 'KISA 인터넷보호나라&KrCERT' 홈페이지(www.boho.or.kr) → 상담및신고 → 해킹 사고

□ 기타 문의사항
 o 한국인터넷진흥원 사이버민원센터: 국번없이 118

참고사이트
[1] apache 보안업데이트 현황 : https://logging.apache.org/log4j/2.x/security.html
[2] 취약점 정보 : https://nvd.nist.gov/vuln/detail/CVE-2021-45105
[3] 신규버전 다운로드 : https://logging.apache.org/log4j/2.x/download.html
[4] 취약점 정보 : https://nvd.nist.gov/vuln/detail/CVE-2021-44832
[5] Log4j 2.12.4, 2.3.2 다운로드 : https://archive.apache.org/dist/logging/log4j/
[6] 취약점 정보 : https://logging.apache.org/log4j/1.2/


□ 작성 : 침해사고분석단 취약점분석팀
TOP

INFORMATION

하단정보
회사명 (주)사이버텔브릿지
대표 남백산
사업자번호 305-81-38619

CONTACT

하단정보
전화
본사 :
02 · 6956 · 6330
A/S센터(PTT) :
02 · 6956 · 7576
시흥공장 :
070 · 8676 · 7770
BAPS솔루션(A/S) :
1644 · 3580

BAPS솔루션(영업) :
02 · 867 · 4208
팩스 02 · 6956 · 6377
이메일 sales@everytalk.co.kr

LOCATION

본사 :
서울특별시 구로구 디지털로 272 한신아이티타워 901~904호
시흥공장 :
경기도 시흥시 매화산단 3길 67, 2층 사이버텔브릿지 시흥공장

COPYRIGHT (C) BY 2021CYBERTELBRIDGE. ALL RIGHT RESERVED.